Usage of "site:" in query prevents faceted search from working

May 8, 2008 at 6:39 PM
While experimenting with the faceted search under MOSS 2007 I encountered a strange bug. If I type a query like "apple Author:John" everything works well and the faceted search web part gives me a nice view of the facets found in the resultset. However if I specify " apple site:"\\servername\share" " as the query, even though the same documents are returned, nothing appears from the faceted search web part. After some recompiling/debugging, I found that the SQL syntax used to extract the metadata properties seems incorrectly formatted. At least I could not get it to return any results when pasting it in the Sharepoint Search Service Tool (found under http://www.codeplex.com/SharePointSearchServ). Any help appreciated!

Harold
Coordinator
May 16, 2008 at 5:37 PM
Please submit as an issue in the Tracker

hroussel wrote:
While experimenting with the faceted search under MOSS 2007 I encountered a strange bug. If I type a query like "apple Author:John" everything works well and the faceted search web part gives me a nice view of the facets found in the resultset. However if I specify " apple site:"\\servername\share" " as the query, even though the same documents are returned, nothing appears from the faceted search web part. After some recompiling/debugging, I found that the SQL syntax used to extract the metadata properties seems incorrectly formatted. At least I could not get it to return any results when pasting it in the Sharepoint Search Service Tool (found under http://www.codeplex.com/SharePointSearchServ). Any help appreciated!

Harold