This project is read-only.

Javascript errors when using Advanced Search

Aug 21, 2008 at 4:26 PM
I just installed the 2.5 Beta.  When I use the Basic Search page, everything works OK.  When I try to use the Advanced Search Query screen, it works for a few seconds, then a Javascript error comes up saying "Line 185: Char: 13 Error: Function expected Code 0"  or an "Object unexpected"  error and the Progress bar keeps going on forever.   Any idea what could be causing this.   I have received this error using IE 6 and 7.

Thanks.
Aug 26, 2008 at 5:05 PM
I loaded the Microsoft Script debugger, and it looks like it is giving a Javascript error in WebResource.axd in the function

WebForm_ExecuteCallback(callbackObject)
 
the line that is failing is:

callbackObject.errorCallback(response.substring(1), callbackObject.context);

any ideas as to what could be causing this?

The webpart works fine when calling it from the Basic Search Query, but when called from the Advanced Search page, it consistently throws this error.

Thanks.
Nov 24, 2008 at 9:31 AM
Hi,
I just installed the 2.5 Beta. I have search scopes checkboxes in Advanced Search page. When search without selecting scopes the faceted web part works fine. But when i select any ONE Scope, the faceted searhc doesn't displaying the facets, its showing EMPTY.

Please help me in this regard


Thanks
Meera
Nov 24, 2008 at 9:20 PM
Okay it appears that there is clearly an issue here.  Please could you post to the Issue Tracker list so we can keep this in focus, along with a full and complete description of the problem you are having.

Thanks,

Shaun O'Callaghan