Enterprise Library Config

Sep 9, 2008 at 11:14 PM
Getting errors: Unable to cast object of type 'System.Configuration.DefaultSection' to type 'Microsoft.Practices.EnterpriseLibrary.Caching.Configuration.CacheManagerSettings'

What am I doing wrong?

Thanks.
Developer
Sep 10, 2008 at 8:16 AM
Hi,

Many thanks for your email.

Have you deployed Faceted Search via the installer or have you made custom modifications from the code?  Did you follow the deployment/installation instructions etc?

Kind Regards,

Shaun O'Callaghan

Jan 23, 2009 at 12:49 PM
Hi, I have the same problem and have followed all steps like described in the Setup Guide. Is there any solution available? Thx.

Regards, Eric
Feb 3, 2009 at 6:17 PM
Hi,

Check that the first Enterprise Library block in web.config are directly beneath: <ConfigSections>
Not beneath <sectionGroup name="SharePoint">
It's easy to paste it wrong.

// Mike



 

Jun 11, 2010 at 3:31 PM
I have the same problem. I am trying to install Version 3. I followed the instructions in the Setup_Guide, and also checked to make sure I pasted the code under the <ConfigSections>, and I get the same error.
Jun 11, 2010 at 4:28 PM

I answered my own question.  I copied the code in the wrong section.  I thought "Insert right after <configSections>" meant to insert it after that section, but it means copy it directly under <configSections>.   When I moved it into the correct section, it worked.