Is Enterprise Library a prerequisite ?

Sep 15, 2008 at 3:36 PM
We have just tried to install Faceted Search 2.5 on one of our MOSS servers.
we thought that all the Enterprise Library stuff was optional (there was only 1 wsp in previous releases).
we were apparently wrong since our setup failed when trying to install FacetedSearch only (error when previewing searchfacets.webpart).
Can someone confirm that Enterprise Library is a prerequisite ?
Developer
Sep 16, 2008 at 8:56 AM
Many thanks for your email.

I can confirm that Enterprise Library 3.1 is a prerequisite for Faceted Search 2.5 beta.

Thanks,

Shaun
Sep 17, 2008 at 1:23 PM

I presume the Faceted Search Webparts will be distributes automatically to the webservers in a load balanced configuration, but the  the Enterprise Library needs to be installed and configured manually on each Webserver?

Can someone confirm please?

Thanks,
Henk Visser
Developer
Sep 17, 2008 at 1:39 PM
Yes that's correct.  You will need to deploy the Enterprise Library to the GAC on each machine where Faceted Search runs.

Thanks,

Shaun O'Callaghan