Failure to add assembly to GAC

Nov 5, 2008 at 2:34 PM
Hi,

I am installing Faceted Search and I cannot pass the first step with installing Enterprise Library. When I run Gac_EntLib.bat I got an errors like this for each DLL:

Failed to add assembly c:\tmp\Microsoft.Practices.ObjectBuilder.dll to the cache: Unknown Error


My Gacutils.exe appears to be in "c:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\gacutil.exe" though I thought that MOSS uses v2.0. I have 2.0 installed but it does not have gacutils.exe. Also I do not have assembly application on my computer at all so I cannot try the alternative way to GAC dlls. MOSS it working fine though.

I tried to skip first step but, as someone already told in this group - everything installs but the Search Facet WEB Part does not work complaining on missing dependency from ent.

What would you recommend me to do?

Thank you
Igor
Coordinator
Nov 6, 2008 at 6:59 PM
You might try getting correct gacutil.exe from any machine with Visual Studio and .Net 2.0. Otherwise, typing assembly in the run box should bring the GAC up