No Scope Named <N>

Apr 2, 2009 at 3:38 PM
Hi,

I used MOSS strickly for seaching purposes and this feature is one great addition..

However i have encountered the following issue:

When i perform using the Top Right Search bar and select a scope, the search is successfull and the facet seach populates the scopes correctly. However when i perform a search from the Advanced Search and select a scope (When i do not select a scope it works), the search goes through but the facet is not displayed with the following error "No Scope named 4"

Any idea what the problem might be cause this tool is surely usefull!
Coordinator
Apr 2, 2009 at 7:05 PM
Advanced search will be significantly improved in 3.0
Apr 3, 2009 at 10:14 AM
Would you know approximatly when we should expect 3.0?

If you require some BETA testing, I am willing to help..

Thanks,
Coordinator
Apr 3, 2009 at 11:40 AM
3.0 Alpha is posted and you are more than welcome to test scopes
Apr 3, 2009 at 11:43 AM
Great.. will install and keep you posted!
Apr 8, 2009 at 10:07 AM
Edited Apr 8, 2009 at 10:09 AM
I am about to install the Alpha... however im wondering if i should run CreateCachingDatabase.sql once again?

Thanks!
Apr 8, 2009 at 1:27 PM
I have installed version 3.0 and can confirm that it does correctly build the faceted webpart correclty...

However when i come to click on a facet, an exception is generated in MOSS... Also.. When i try to 'Edit Page' in the Search results an exception is generated (which means i cannot add  / remove the webpart... this is quite an issue)

Any ideas on how to resolve the problem? I am relatively new to MOSS

Thanks
Coordinator
Apr 8, 2009 at 2:19 PM
Can you provide entries in Event log please
Apr 8, 2009 at 2:26 PM
Edited Apr 8, 2009 at 2:27 PM
Thanks for your reply leon,

One thing that i knoticed is that i am not using the Facet search page layout in my Search Page.. (The problem i am having this is that i do not have the option  'Page layouts and site templates' under neath my search center site settings. I only have this option in the site settings in my Portal.

Event Log Entries are as follow:

When i click on a Facet Search result:

Event Type:    Error
Event Source:    Enterprise Library Data
Event Category:    None
Event ID:    0
Date:        4/8/2009
Time:        4:22:25 PM
User:        N/A
Computer:    SUPPORTSP
Description:
An error occurred in application /LM/W3SVC/863265574/Root-1-128836711674465880 in the Enterprise Library Data Access Application Block.
The error occurred using the "Connection String" database instance while attempting to open the database connection.
The connection string used was "data source=;initial catalog=caching;integrated security=true;".
The exception that occured was: System.Data.SqlClient.SqlException: An error has occurred while establishing a connection to the server.  When connecting to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server)
   at System.Data.SqlClient.SqlInternalConnection.OnError(SqlException exception, Boolean breakConnection)
   at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj)
   at System.Data.SqlClient.TdsParser.Connect(ServerInfo serverInfo, SqlInternalConnectionTds connHandler, Boolean ignoreSniOpenTimeout, Int64 timerExpire, Boolean encrypt, Boolean trustServerCert, Boolean integratedSecurity, SqlConnection owningObject)
   at System.Data.SqlClient.SqlInternalConnectionTds.AttemptOneLogin(ServerInfo serverInfo, String newPassword, Boolean ignoreSniOpenTimeout, Int64 timerExpire, SqlConnection owningObject)
   at System.Data.SqlClient.SqlInternalConnectionTds.LoginNoFailover(String host, String newPassword, Boolean redirectedUserInstance, SqlConnection owningObject, SqlConnectionString connectionOptions, Int64 timerStart)
   at System.Data.SqlClient.SqlInternalConnectionTds.OpenLoginEnlist(SqlConnection owningObject, SqlConnectionString connectionOptions, String newPassword, Boolean redirectedUserInstance)
   at System.Data.SqlClient.SqlInternalConnectionTds..ctor(DbConnectionPoolIdentity identity, SqlConnectionString connectionOptions, Object providerInfo, String newPassword, SqlConnection owningObject, Boolean redirectedUserInstance)
   at System.Data.SqlClient.SqlConnectionFactory.CreateConnection(DbConnectionOptions options, Object poolGroupProviderInfo, DbConnectionPool pool, DbConnection owningConnection)
   at System.Data.ProviderBase.DbConnectionFactory.CreatePooledConnection(DbConnection owningConnection, DbConnectionPool pool, DbConnectionOptions options)
   at System.Data.ProviderBase.DbConnectionPool.CreateObject(DbConnection owningObject)
   at System.Data.ProviderBase.DbConnectionPool.UserCreateRequest(DbConnection owningObject)
   at System.Data.ProviderBase.DbConnectionPool.GetConnection(DbConnection owningObject)
   at System.Data.ProviderBase.DbConnectionFactory.GetConnection(DbConnection owningConnection)
   at System.Data.ProviderBase.DbConnectionClosed.OpenConnection(DbConnection outerConnection, DbConnectionFactory connectionFactory)
   at System.Data.SqlClient.SqlConnection.Open()
   at Microsoft.Practices.EnterpriseLibrary.Data.Database.GetNewOpenConnection()

When i click on the Edit Settings Button:


Event Type:    Error
Event Source:    Enterprise Library Logging
Event Category:    None
Event ID:    0
Date:        4/8/2009
Time:        4:22:25 PM
User:        N/A
Computer:    SUPPORTSP
Description:
An error occurred in application /LM/W3SVC/863265574/Root-1-128836711674465880 in the Enterprise Library Logging Application Block.
Failure while sending log entry to the TraceListeners.
The exception that occured was: System.Security.SecurityException: Requested registry access is not allowed.
   at System.ThrowHelper.ThrowSecurityException(ExceptionResource resource)
   at Microsoft.Win32.RegistryKey.OpenSubKey(String name, Boolean writable)
   at System.Diagnostics.EventLog.CreateEventSource(EventSourceCreationData sourceData)
   at System.Diagnostics.EventLog.VerifyAndCreateSource(String sourceName, String currentMachineName)
   at System.Diagnostics.EventLog.WriteEvent(EventInstance instance, Byte[] data, Object[] values)
   at System.Diagnostics.EventLog.WriteEvent(EventInstance instance, Object[] values)
   at System.Diagnostics.EventLogTraceListener.TraceData(TraceEventCache eventCache, String source, TraceEventType severity, Int32 id, Object data)
   at Microsoft.Practices.EnterpriseLibrary.Logging.TraceListeners.FormattedTraceListenerWrapperBase.TraceData(TraceEventCache eventCache, String source, TraceEventType severity, Int32 id, Object data)
   at Microsoft.Practices.EnterpriseLibrary.Logging.LogSource.TraceData(TraceEventType eventType, Int32 id, LogEntry logEntry, TraceListenerFilter traceListenerFilter)
   at Microsoft.Practices.EnterpriseLibrary.Logging.LogWriter.ReportExceptionDuringTracing(Exception exception, LogEntry log, LogSource traceSource)
The Zone of the assembly that failed was:
MyComputer


For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

I managed to remove the webpart by editing the default results.aspx page.

Thanks Leonidly!

Apr 8, 2009 at 2:29 PM
Hmmm..... event log shows something interisting...

I am using the inbuilt version of SQL with MOSS.. could this be a problem?

Thanks!
Coordinator
Apr 8, 2009 at 2:53 PM
You have to make sure that Caching database is created and web.config is updated accordingly. Steps are in the guide
Apr 9, 2009 at 12:28 PM
I can confirm that the Connection String and Shared Services are correct and ENT Lib correctly builds the web config

Connection Sting / Connection String: Data Source=;Initial Catalog=Caching;Integrated Security=True
SharedServices / Connection String: Data Source=localhost ;Initial Catalog=SharedServices1_DB;Integrated Security=True

Also, I am able to view the Caching Database and the dbo.CacheData Table (empty at this point) in SQL Server Managment Studio...

Any further ideas on what might be the cause of the issue?

I knoticed that i get the exact same error when i try to connect to the SQL database using SQL Studio Manager from a remote machine (also in my test setup). Is this normal?

Named Pipes and Remoting / Browser Service started...

Thanks!
Coordinator
Apr 9, 2009 at 1:32 PM
You will have to continue troubleshooting the Ent Lib setup.There is nothing in the log that refers to the Ffaceted Search.  It might happen that one of required services or registrations failed. Also look at your web.config using EntLib Configuration console. It might show errors. Further, check on your errors at the Ent lib forum on CodePlex.
Apr 9, 2009 at 1:33 PM
I was getting the error in SQL management studio because i needed to specify the instance, i.e. machinename/officeservers..

Tried doing the same in the SharedServices, but obtain the same error:

SharedServices / Connection String: Data Source=machine/officeservers ;Initial Catalog=SharedServices1_DB;Integrated Security=True
Apr 9, 2009 at 1:34 PM
cheers leon... Will do!
Apr 9, 2009 at 2:24 PM
Leon,

I think there might be a problem in the Setup Guide..

In version 3, there are two connection strings as documenteded in your Setup Guide:

<connectionStrings>
  <add name="Connection String" connectionString="Data Source=;Initial Catalog=Caching;Integrated Security=True" providerName="System.Data.SqlClient" />
  <add name="SharedServices" connectionString="Data Source=<YOUR SQL SERVER NAME> ;Initial Catalog=SharedServices1_DB;Integrated Security=True" providerName="System.Data.SqlClient" />
</connectionStrings>

However, only the SharedServices Connection String contains the <YOUR SQL SERVER NAME>, whilist the 'Connection String' Connection String does not have this information.

I noticed that the event log was indicating to "data source=;initial catalog=caching;integrated security=true;"...  i guess this is becuase the connection string was not set.

<add name="Connection String" connectionString="Data Source=SUPPORTSP\OFFICESERVERS ;Initial Catalog=Caching;Integrated Security=True"
      providerName="System.Data.SqlClient" />
    <add name="SharedServices" connectionString="Data Source=SUPPORTSP\OFFICESERVERS ;Initial Catalog=SharedServices1_DB;Integrated Security=True"
      providerName="System.Data.SqlClient" />

After I did the change the following Event was created:

Starting up database 'Caching'

Was the above change needed? Mind you.. it is still not working however am i a step further?

Cheerz!



Coordinator
Apr 10, 2009 at 10:22 PM
The connection string is fine. You have to make sure that Ent Lib is installed correctly. BTW, you can use any supported CachingProvider, not just SQL-driven. Again, all these details belong to Enterprize Library.
Coordinator
Jul 11, 2009 at 7:28 PM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.