This project is read-only.

Install - Caching not working - where is the SQL Script? And do I need to configure the SSP in the web.config?

May 11, 2009 at 12:52 AM

Hi All

I have installed the beta released of Faceted Search, a very nice upgrade from 2.5. with the new features.

I previously had 2.5, uninstalled this then followed the setup guide for 3.0.

First problem to be clarified - The Entlib caching section in the new setup guide says to run CreateCachingDatabase.sql, this was fine in Faceted Search 2.5/Enterprise Library 3.1 as it included this file in the zip package. The new enterprise library 4.1 seems to be missing this SQL scipt - where is it? After giving up trying to find it I installed the solution anyway (after configuring the web.config as per the setup guide) and it all works except the caching (as I expected).  I have tried the a caching database created from the old Enterprise Library 3.1 SQL Script (as I cannot find a SQL script in enterprise library 4.1 package, it is also an EXE not a ZIP Package anymore), and now the final installed solution it does not work with caching (if you tick enable caching in the Search Facets webpart it performs the query really slowly and does not cache).

Second problem to be clarified - the new web.config configuration has the following

<connectionStrings>

  <add name="Connection String" connectionString="Data Source=;Initial Catalog=Caching;Integrated Security=True" providerName="System.Data.SqlClient" />

  <add name="SharedServices" connectionString="Data Source=<YOUR SQL SERVER NAME> ;Initial Catalog=SharedServices1_DB;Integrated Security=True" providerName="System.Data.SqlClient" />

</connectionStrings>

Are you meant to point the web.config file to the name of your Shared Service Provider database? if so ours has a different name from SharedServices1_DB. And the first line doesnt have a data source defined - is this correct? Or is it meant to be just one line to the caching DB?

Thank you for a lot of hard work into what looks to be a great product - would appreciate if the two problems above can be solved for a working solution.

Regards

Anthony

May 11, 2009 at 2:44 AM

Anthony, thanks for reporting these issues. Your request to include EntLib SQL scripts is well taken. Meanwhile you might check documentation for EntLib 4.1 or their forum.

You're correct, the 2nd connection is defined for SSP. It is required for the Search Hint web part.

May 11, 2009 at 6:46 AM
Edited May 11, 2009 at 6:48 AM

Thanks - I will see if I can see if there is an updated SQL script from the EntLib 4.1 Project. I will then report back to this thread if there is an updated SQL Script...

I modifed the connectStrings as below:

<connectionStrings>

  <add name="Connection String" connectionString="Data Source=<YOUR SQL SERVER NAME>;Initial Catalog=Caching;Integrated Security=True" providerName="System.Data.SqlClient" />

  <add name="SharedServices" connectionString="Data Source=<YOUR SQL SERVER NAME> ;Initial Catalog=<YOUR SHARED SERVICE PROVIDER DB NAME>;Integrated Security=True" providerName="System.Data.SqlClient" />

</connectionStrings>

Now I can tick Caching in the Search Facets webpart, it is not slow to query with this ticked on anymore -  however is it still showing as Not Cached. Will have an attempt to solve this...

Note: It is referencing the caching DB created with the 3.1 EntLib SQL Script (maybe it needs an update for the 4.1 Entlib?).

 

May 13, 2009 at 4:34 PM
Edited May 14, 2009 at 12:24 AM

Hi Anthony

I've been experiencing the exact same issue as you but I am using it as a test with Search Server Express 2008 and SQLExpress.

I noticed the web.config entries as well, my database is SharedServices1_DB...GUID.... and based on your comments I'll change the entries to that.

I have found and run the CreateCachingDatabase.sql but its still displaying Not Cached as well.

Cheers

Colin

May 15, 2009 at 12:55 PM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.