Facets doesn't show all content types

Jul 7, 2009 at 12:50 AM

Hi,

I just upgraded to version 3.0. One thing i noticed is the content type facet doesn't show all content types that are returned from the search results. For example, in the search results, i can see there are many word documents but Word doesn't appear under the Content Type facet.

Do i need to do something to get it show all content types?

Thanks a lot,

 

Jul 9, 2009 at 12:09 AM

Does anyone have any idea? Please help. I need it urgently. Thanks a lot.

Jul 9, 2009 at 11:58 AM

If you could describe (or show us) what you are getting, you might get more of a response.  Busy people tend not to react to vague posts.

Jul 9, 2009 at 10:15 PM

Thanks Andrew. Perhaps you are right :).

I have Facet 3.0 and just use whatever settings are set by default for Content Type. In my Sharepoint Search Administration->Managed Properties, the Content Type is mapped to Basic:5 (Text) and ows_ContentType(Text).

 We allow the users to search on our intranet as well as on our shared drives; however, i found out that Content Type facet seems to ignore any item from shared drives (other facets are fine). I can see in the search core results a number of shared drive documents which are Word documents (in fact they are returned as first entries in the search results). However, in the Content Type facet, it doesn't show Word at all. I have tried to re-index the shared drives many items.

How do i get the Content Type to work on Shared Drives?

I made a test by adding a FileExtension facet and it shows all the file types correctly. However, we cannot use FileExtension mapping because version 3.0 wildcard doesn't have option to group all "ASP?id=" pages as one entry in the facet and we don't want to exclude ASP pages from the facet.

Any idea please?

Thanks

 

 

 

 

Jul 10, 2009 at 12:13 PM
Edited Jul 10, 2009 at 12:14 PM

I see what you mean.  I had never noticed that before.  It seems that you are right - the local storage iFilter does not attempt to discern a content type at all, all you have for those files is the file type.

However, I am not sure what you mean by your reference to the wildcard option - I haven't tried it on file extensions, but I would be suprised if something like 'Mapping Match="ASP%" DisplayName="ASP" Image="html16.gif" ' wouldn't work.

Is that what you tried?